LastPass patched a bug that could have exposed your passwords

If you use LastPass to manage your passwords, now would be a good time to make sure you're running the latest version, 44.33.0. As Gizmodo reports, LastPass recently patched a bug that could have been used to compromise users' security credentials. T…

via Engadget RSS Feed

Check out the Finding Your Identity Podcast!

Tags: , ,
Travel Back Up To The Top!